

1. COMPUTER GENERATIONS



1. Fill in the blanks :-

1.  Electronics technology developed after the invention of the vacuum tube devices.
2.  First generation of electronic computers were built using vacuum tube devices.
3.  The CPU forms the essential component of modern stored-program computers.
4.  Second generation computers were built using transistors.
5.  A computer that is an order of magnitude more powerful than other computers of its generation is called a super computer.
6.  Keyboards as input devices came into use during the third generation of computers.
7. GUI is a feature of the fourth generation of computers.

2. State whether the following statements are true or false :

1.  Replacement of vacuum tubes with transistors reduced the size of computers.
     Ans-> True.
2. First generation computers used keyboards for inputs.
      Ans -> False.
3. Magnetic core memory were used in the second generation computers.
      Ans -> True.
4. Operating systems when they were introduced had a graphical user interface.
     Ans -> False.
5. Semiconductor memory was used in the third generation computers.
     Ans -> True.
6. A microprocessor is an integrated circuit.
     Ans -> False.
7. Jack kilby’s integrated circuit was known as CPU on chip.
     Ans -> False.

3.  Distinguish between :-

	1.Vacuum Tubes
	Transistors   

	1. Large in size.
	1 Small in size.

	2. Consumed lot of energy.
	2.Consumed less energy.

	3. Produced too much heat.
	3. Produced less heat.



	2.Second generation  Computers
	Third generation computers

	1. Punched cards are used for input
	1. key boards are used for input

	2. Magnetic drum memories are used
	2. Semiconductors are used as memory.

	3. Transistors are used.
	3. Integrated circuits are used.



  

 4. Answer the following questions in one or two sentences each :-
 1.  What is meant by computer generations?
 Ans:-Computers’ are categorized on the basis of technology used to build its electronic  components. Computers’ that are built by a specific technology is belongs to that technology.
 2.  Why were the first generation computers huge in size?
 Ans:- The first generations of computers’ were built by vacuum tube technology. The Vacuum tubes were big in size and they produced lot of heat. So they had to be cooled by big air conditioners. So they were big in size.
 3.  What is a supercomputer?
  Ans:-A computer that is about ten times powerful than other computer of its generation is called supercomputer.
 4.  What is an integrated circuit?
  Ans:-Connection of several transistors together into a single miniaturized processing board is called an integrated circuit.
5. Answer the following questions in brief : (Write answers in your notebook.)
1.  State any five features of the third generation computers.
  Ans:-    
       a) Transistors were replaced by integrated circuits.
       b) They generated less heat and consumed less energy.
       c) Semiconductor memory was invented.
       d) The size of the computer was remarkably small.
       e) CD-ROM was introduced.

2. State any five features of the fourth generation computes.
  Ans:-
       a) These computers were made using microprocessors.
       b) Graphic user interfaces were introduces.
       c) Floppy disk was introduced.
       d) Local area Networking technology was developed.
       e) Home game system Became available.

3. What are the technologies being envisaged for future generation of computers?
   Ans:- 
      a) Computers are planned to design with artificial intelligence.
      b) The goal is to develop the computers that respond to natural languages.
      c) Computers should be able to learn-self.
      d) Quantum computing is planned.
      e) Speech processing, vision system, robotics abilities are determined to include.


2.INTRODUCTION TO CURRENT DEVELOPMENTS IN COMMUNICATON
1.Fill in the blanks :-
1.RAM is a volatile memory.
2.Contents of Read Only Memory are not erased even when the computer is switched off.
3.Dynamic RAM needs to be constantly refreshed.
4.Static RAM is faster but costlier.
5.A pen drive is a removable media secondary memory.
6.SRAM built into a microprocessor is called a Cache
7.An SMS text message can contain up to 160 English characters and symbols.
8.Using your cell phone outside your home area is called as Roaming.
9.INSAT System is India’s domestic communication satellite system.
10.A customer care Centre handles mainly inbound calls.
11.Direct marketing through telephone is known as telemarketing.
12.A face-to-face meeting of two or more persons is called a videoconferencing.
13.Call conference service of MTNL/BSNL allows a teleconference among a maximum of 5 persons.
2.      Distinguish between :
	1. RAM
	ROM

	1.This is a short term memory.
	1.This is a long term memory.

	2.Temporarily holds the data
	2.Permanently holds the data.

	3.When you switched off the computer all the data written in the RAM are erased, Thus RAM is a volatile memory.
	3.ROM retains its programs or data even when it is not electrically powered. Thus ROM is a non-volatile memory.



         
	2.SMS (Short Message Services)
	Multimedia Message Services

	1.SMS helps to send text messages
	1. MMS Helps to send Text, Video, Picture  and Sound files.

	2.SMS is cheaper than MMS
	2. MMS is costlier than SMS




3.Give the names of :

1.The two types of primary memory :- RAM (Random Access Memory) and ROM (Read Only Memory)
2.The two types of RAM :- Static Ram and Dynamic Ram
3.Removable media type of long-term memory :- Compact Disk and Pen drive.
4.The parts of a microprocessor:- Control Unit, Memory Registers and Arithmetic and Logic Unit.
5.Names of major microprocessor:- AMD,IBM and Intel.
6.The two types of call centers :- Customer care center and telemarketing.
7.The two conferencing techniques using modern communication technologies:- Tele conferencing and video conferencing.
8.The central room from which the path and operations of a satellite is controlled:- Mission Control room.

4.Write the expanded forms of the following abbreviations:-
1.DRAM:-Dynamic Random Access Memory.
2.SRAM:-Static Random Access Memory.
3.ROM:-Read Only Memory.
4.EEPRO:-Electrically erasable programmable memory.
5.ALU:- Arithmetic And Logic unit
6.MHz: -Mega Hertz.
7.Mips:-Million instructions per second.
8.AMD:- Advanced Micro device.
9.SMS:- Short Message Service.
10.INSAT:-Indian National Satellite.
11.WLL:- Wireless local loop
12.VolP:-Voice over Internet Protocol.

5.State whether the following statements are true or false:-
1.Primary memories are volatile. True.
2.Memory locations in a RAM can be randomly accessed for read-write operations. True.
3.Audio/video cassette tapes are a sequential access. True.
4. A DRAM is faster than an SRAM. False.
5. A CPU cache is a dynamic RAM. False.
6. An USB pen drive is an EEPROM. True.
7. An SMS text message in Hindi can contain up to 160 characters and symbols. False.
8. Cell phone users are charged for alerts messaged to them by the local police or municipality. False.
9. Mobile roaming mode charges are higher than those within your home area. True.
10.A satellite-to-earth communication links called an uplink. False.
11.EDUSAT is the first satellite launched by India. False.
12.An internet call Centre is much cheaper to run than a conventional call Centre. True.

6. Answer the following questions in one or two sentences each :
1.What is meant by a volatile memory?
Ans:-If the data in the memory is get erased in the absents of power supply, that type of memory is known as volatile memory.
2. State the use of ROM as main memory in a computer.
Ans:- ROM holds critical bootstrapping programs that are essential to bring the computer to a state of readiness after it is powered on.
3.What is SMS?
Ans:- SMS is a technology that enables the sending and receiving of messages between mobile phones. 
4. What is MMS?
Ans:-MMS is a technology that allows mobile subscribers to exchange multimedia messages with other mobile subscribers..
5. What are the space and ground segments of a satellite communication system?
Ans:-The space segment consists of one or more satellite. The earth segment consists of number of earth-based stations interconnected by satellite.
6.What are the sues of the INSAT system?
Ans:- INSAT system provides service to telecommunication, television broadcasting, weather forecasting. Disaster warning. 
7.What is Wireless Local Loop?
Ans:-WLL is  a communication system that connects  subscribers to regular telephone network using electromagnetic signals instead of conventional copper wires.  
8.What is a Call Centre?
Ans:- A call center is a centralized office used for handling a large volume of operator –supported inbound and outbound telephone calls.
9.Which qualities are required in a Call Centre representative?
Ans:-A call center job requires good communication skills, politeness and lot of patients.
10.What is an Operator Control Room?
Ans:- Operator control room is a single room from which one or more operators supervise and control all the automatic equipment of an industry.

3. INTRODUCTION TO INTERNET

1. Fill in the blanks:
(1) The cable connecting the web servers are called information super highways.
(2) Local area networks are connected to the web servers through Routers.
(3) Sending a file to FTP web server is called uploading.
(4) The protocol used for retrieving hyperlinked resources from web servers called downloading.
(5) Post office protocol is used by mail servers to send and receive mail messages to and from other mail servers.
(6) The root page of a web site is called Homepage.
(7) The internet user needs a program called a browser to access information on the WWW.
(8) The name with which you open your account with ISP is called your user name.
(9) The process of establishing a connection with your ISP's server is called logging in.

2.State whether the following statements are true or false:
(1) The Internet is global network of networks. True.
(2) ARPANET was created for the US military. True.
(3) E-mail clients use SMTP to access their mailbox accounts. True.
(4) A web site consists of a group of hyperlinked webpages. True.
(5) WWW is a synonymous with the internet. True.
(6) An IP Address has two sections identifying the network and host. True.
(7) Domain names are based either on the type of organization or the geographical area or both. True.
(8) The web browser of Netscape is called Firefox. False.
(9)  A dial-up access remains ‘always on’. False.
(10) You can attach files of any type to your e-mail messages. True.
(11) The URL of a web site begins with the domain name. False.
(12) The URL of a website contains @ symbol. False

3.Match the following.
	Column 1
	Column 2

	(1)    .in
	(d) India

	(2)    .int
	(e) International Organization

	(3)    SMTP
	(b) Email

	(4)    HTML
	(c) Wep page

	(5)    URL
	(a) Web address



4. Correct the following URLs and rewrite them:
	(1)    www msn.com
	www.msn.com

	(2)    http\\www.navaneet.com
	http://www.navneet.com

	(3)    ftp:\\www.nic.ORG
	ftp://www.nic.org

	(4)    www:\\Vsnl.net.IN
	www.vsnl.net.in

	(5)    COM.khoj.www
	www.khoj.com

	(6)    NPIL @ / Navneet.com
	npil@navneet.com




5. Write the full form of the following.
	(1)    .com
	Commercial.

	(2)    .gov
	Government

	(3)    .edu
	Education

	(4)    .mil
	Military

	(5)    .au
	Australia

	(6)    .jp
	Japan

	(7)    .in
	India

	(8)    IMAP
	Internet Message Access Protocol

	(9)    HTTP
	Hypertext Transfer Protocol.

	(10)  URL
	Universal Resource Locator.



6.Name the following.
(1) A company which provides Internet connectivity to users:
Ans. Internet Service Provider.
(2) Large fibre-optic cables connecting the web servers:
Ans.Information Super Highways.
(3) A software programs that searches the WWW on the basis of keywords provided:
Ans.Search Engine.
7.Answer the following questions in one or two sentences each.
(1) Why are networking protocols necessary?
Ans. Protocols are necessary because computers accross a network have different hardwares and operating sysytem.
(2) Name the most important protocols for data transmission over the internet?
Ans. Transmission Control Protocol (TCP) and Internet Protocol (IP).
(3) Name three e-mail related protocols.
Ans. Post Office Protocol(POP),Internet Message Access Protocol (IMAP) and Simple Mail Transfer Protocol(SMTP.
(4) What is world wide web?
Ans. The world wide web is a collection of interconnected documents and other resources,linked by hyperlinks and web addresses.
(5) What is a search Engine?
Ans. Search engines are powerfull software programs that search information on the basis of the keyword that you provide.
(6) State the requirements for an internet connectivity?
Ans.To connect to the internet you need Personal Computer, Modem, Interner service Provider (ISP), Communication link to ISP and relevant software(Browser).
(7) Name the different types of communication link to ISP
Ans. Dial-up access, Broadband ADSL connectivity, ISDN, Leased lines,VSAT and Cable TV.
(8) What is mail client?
Ans. Mail client is a software residing in your computer that allows you to send and recieve e-mail messages.
(9) Name two popular mail clients?
Ans. Microsoft Out look express and Netscape Mail.
(10) What is the advantage of using web mail?
Ans. Webmail is a web-based e-mail that only need a browser. Websites such as yahoo.com, gmail.com and hotmail.com and rediff.com offeres web-based e-mail.

4. OFFICE AUTOMATION TOOLS
1. Fill in the blanks:
(1)Word is a word processor.
(2)Word automatically adds an extension of .Doc at the end of filename of a word document.
(3)Mistakes and errors in a document can be corrected with the help of spellings and grammar checkers.
(4)To insert pictures in your document, click on insert menu on the menu bar.
(5)The Standard toolbar in Microsoft word contains the tool buttons for opening an existing or a new blank Word document.
(6)You will find the tool buttons for Bulleting and numbering on the Formatting toolbar of Microsoft word.
(7)The paragraph dialog box in Microsoft word can be opened by clicking on the Format menu on the Menu bar.
(8)A file created in PowerPoint is called Presentation.
(9)Slides are simply names given to different pages of your presentation.
(10)Power point file have an extension .ppt.
(11)The outlined area on a slide for entering text is called Textbox.
(12)You use the Normal, slide sorter and Slide show buttons to look slides in different ways.
(13)Auto Content Wizard has Five steps.
(14)You can use the Slide sorter View in PowerPoint to view miniatures of all slides together
2. State whether the following statements are true or false.
(1) The buttons on the standard toolbar in Word are shortcuts to the most frequently used main menu commands including those for editing. True
(2) You can find the tool buttons to draw lines and arrows in a word document on the formatting toolbar. False
(3) You can press Ctrl + B key combination on the keyboard to create a new blank document in Word. False
(4) Text typed on a typewriter cannot be saved. True
(5) You can not save a text document prepared in word. False.
(6) You can include pictures and tables in a document prepared in Work. False.
(7) When you type on keyboard, the text appears on the position of | beam. True
(8) Until you save your document, there is possibility of losing all the text you have typed. True.
(9) Print preview is used to view a document after printing. False.
(10) The computer saves all the word documents in My documents folder. False.
(11) Scrollbars are used to view the parts of the document which can not be fitted on the monitor screen. True.
(12) The graduated scale above the text area is called Ruler. True.
(13)  Power point file have .doc  as file name extension. False.
(14)  An Over-head projector(OHP) can be used for effective class room teaching. True.
(15)  Power point help in making your presentation attractive and interesting. True.
(16) You can not include pictures in PowerPoint slides. False
(17)  Templates guide you through in creating your presentation. True.
(18)  PowerPoint is a hardware program. False.
(19)  Clicking on the place holder deselect the textbox. True.
(20)  The Note Pane in PowerPoint lets you add speaker notes. True.
(21)  In PowerPoint presentation, the same options for slide transition can be applied to all the slides with the click of single button. True.
3. Answer the following questions in one or two sentences each:
(1) State the functions of Print Preview and Insert table tool buttons on the Standard Toolbar in Microsoft Word.
Ans. Print Preview – To view the document as it is printed. Insert Table –To insert table in a word document.
(2)Explain the function of Standard Toolbar in Microsoft Word.
Ans. Standard Toolbar contains the shortcuts to frequently used commands in Microsoft Word. So it makes our work easy.
(3)Write the function of any two icon button on the Standard Toolbar in Microsoft Word.
Ans. New- To open a new blank document. Save – To save the current document.
(4)Explain the function of Formatting Toolbar in Microsoft Word.
Ans. Formatting Toolbar contains the buttons to format a text like alignment, line number, Bold and Italics. We can easily change the font and colour using these buttons.
(5) Write the function of any two icon button on the Formatting Toolbar in Microsoft Word.
Ans. Bold – To make letters bold. Align left – To Align the text to left.
(6)       In how many ways can you align text paragraph? Name them.
Ans. Left Align, Right Align, Center Align and Justify.
(7) What is a presentation?
Ans. Presentation is an effective manner of putting across your thoughts and ideas and feeling so that they are easily understandable.
(8) What are slides?
Ans. Slide is a rectangular composition consisting of text, picture, graph etc. which can be seen on computer screen or viewed in magnified size by a projector during a presentation.
(9) What is called placeholder?
Ans. Place holder is a particular portion or area of a slide which have been marked with a box to hold text,, title, picture or clipart.
(10)  What is PowerPoint used for?
Ans. Power point is using to give a presentation to audience by projecting the slides in succession in order to enable them, to observe each step of the idea and thoughts.
(11)  What are design Templates in MS PowerPoint.
Ans. Design templates are pre designed templates that you can use to create your presentation.  
(12) What is meant by slide design in MS Power Point?
Ans. Slide is a process of preparing a slide by putting Text, Pictures and Sound with appropriate animations.
2. Which menu command or tool will you use to perform each of the following functions?
(1) Open a Word document.
Ans. Start ->All programs ->Ms Office –> Ms Word.
(2)Create a New Word document.
Ans. File -> New.
(3) Close a Word document.
Ans. File -> Close.
(4)Save a Word document for the first time.
Ans. File -> Save.
(5) View a Word document before printing.
Ans. File -> Print Preview.
(6)Print a Word document.
Ans. File -> Print.
(7)Open an existing Word document.
Ans. File -> Open
(8)       Launch PowerPoint.
Ans. Start - >All programs->Ms Office –> Ms Power Point.
(9)       Create new slide.
Ans. File -> New
(10)  Close Power Point.
Ans. File-> Close.
(11)  Open a saved presentation.
Ans. File -> Open

5. BASIC PROGRAMMING.
1. Fill in the blanks:
(1) In computer programming Algorithm refers to a precise method that a computer can use to solve a problem.
(2) An algorithm must always terminate after a finite number of steps.
(3) The person who writes the program is called a programmer.
(4) Selection or branching involves making a choice.
(5) The diamond shaped flowchart symbol is called DECISION BOX.
(6) In a flowchart, the beginning and the end of a program are indicated by TERMINAL BOX.
(7) A Loop is where a part of instructions are repeated until a condition or result is achieved.
(8) Coding means writing the program in computer language.
(9) BASIC,FORTAN and C++ are examples of High level language.
(10) Every statement in a BASIC program should be begin with a Line Number.
(11) A BASIC program file is saved with a extension .Bas.
(12) Character string enclosed within quotation marks is called a  string constant.
(13) In BASIC program, 9.81 is a numeric constant while “9.81” is a string constant.
(14) In a BASIC program , A0 is a numeric variable while C$ is a string variable.
(15) The PRINT statement is used to display numbers and text on the monitor screen.
(16) The INPUT statement displays a question mark on the screen and waits for the user to enter data for the program.
2.    Distinguish between:
	[1]                  Algorithm
	Flow Chart

	Algorithm is a finite step to solve a problem.
	Algorithm is difficult to understand, when compared to flow chart.

	Flow chart is diagrammatical representation of an algorithm.
	Flow chart is very easy to understand.



	[2]                  Process Box
	Decision Box

	Process box shows arithmetic operation on number, or the string 
	Decision Box shows the condition evaluated for selection.

	processing operation on strings of characters.
	



	[3]                  Numeric Constant
	String Constant

	A numeric constant is a number. Eg. 16.5.
	A string constant is a character string enclosed in quotation mark. Eg.   “Navaneet” 



	[4]                  Numeric Variable
	String Variable

	A variable which can be assigned a numeric value is called a numeric variable.
	A variable to which a string constant may be assigned is called  a string variable



3. Match the following

	[1] Column A                       
	Column B

	  1) INPUT A$      
	 (a) Take a string constant from the user and assign it  to a sting variable.

	  2) PRINT A$       
	(b) Display the value of a string variable on the monitor screen.

	  3) LET A = 40     
	(c) Assign a numerical constant to the numerical variable A.

	  4) READ A               
	(d) Assign a numerical constant to the numerical variable A.



	
	
	[2] Column A                                                    
	Column B

	1]
	a) Flow line

	2]
	b) Terminal Box.

	3]
	c) Input/Output Box

	4]
	d) Decision Box

	5]
	e) Process Box






4.State whether the following statements are true or false :
(1) The statement PRINT A will display the capital letter A. True.
(2) In a BASIC program, a READ statement must have at least one accompanying DATA statement. True.
(3) DOLLAR $ is a valid string variable. False.
(4) The CLS statement should appear preferably at the end of the BASIC program. False.
(5) Every Basic Program should have a END statement at the end of the program. True.
(6) It is not necessary to give a line number in a BASIC program. False.
(7) The BASIC expression 8^-3 means the cube root of 8. False.
(8) A PRINT statement displays a question mark on the screen. False.
(9) REM statements are displayed on the monitor screen as input prompts for the user. False.
(10)     If A= 16.3 and B= 21.8, then the BASIC statement LET B=A will change the value of B but not that of A. False.
5.Answer the following questions in one or two sentences each :
(1)What is a program?
Ans. The complete set of instruction to solve a problem (in computer language) in a finite number of steps is called a program.
(2)What is an algorithm?
Ans. Algorithm is a finite step to solve a problem.
(3)What is a flow chart?
Ans. Flow chart is diagrammatical representation of an algorithm.
(4)What is a numeric expression?
Ans. Any ordinary algebraic expressions involving numeric constants and variables are called numeric expression.
(5)What is   meant by string concatenation?
Ans.  It is process of combining string and string variables, one behind other.
(6)What is branching? what is conditional branching?
Ans. The transfer control from one part of program to another is called branching. If a branching is based on the outcome of a logical decision is called conditional Branching.
(7)What is compiler?
Ans. A compiler is built in program which creates machine code instruction from the high level language.
(8)What is an interpreter?
Ans. An interpreter translates and executes high level language line by line.
(9Name four commonly used high-level languages.
Ans. FORTAN, APL, BASIC and C++.
(10)What does the acronym “BASIC” stand for?
Ans. Beginners All-purpose Symbolic Instruction Code.
(11)When and by whom BASIC was originally developed?
Ans. The BASIC language was created by John Kemeny and Thomas Kurtz at mouth College, U.S.A., in 1964.
(12)In Basic what symbols are used to indicate addition, subtraction, multiplication, division and exponentiation?
Ans. +  = Addition, - = Subtraction, * = multiplication, / = subtraction and ^ = exponentiation.
6.What are the uses of the following flowchart symbols?
(1)Terminal box: Marks the beginning (START) and editing (STOP) of the program flow.
(2)Process box : Shows the arithmetic operation on numbers, or the string.
(3)Decision box :Shows the condition evaluated for selection.
7.Write the basic expression for :
1)Raising 2 to the power 5:  2^5
2)A3-7B+1: (A^3)  - (7*B) +1
3)5(F-32)  : (5*(F-32))/9
4)AMT=PRIN (1+RATE/100)N.  PRIN * (1+(RATE/100)) N.
8.Identify the valid numeric Variables: M, N7, P$, Q#, INT, 7B.
Ans. M, N7, INT, 7B
9.Identify the valid string Constant : “Navaneet, “NPIL”,”INFO-TECH”,34.35,”9.8”.
Ans. “NPIL”,”INFO-TECH”,”9.8”.



